Allow SRCREV handling through poky-agl.conf
[AGL/meta-agl-demo.git] / recipes-demo-hmi / mediaplayer / mediaplayer_git.bb
index ee86d28..8a7fd62 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
@@ -16,3 +16,7 @@ inherit qmake5 aglwgt
 
 # build-time dependencies
 DEPENDS += "sqlite3 qtquickcontrols2 qtmultimedia"
+
+RDEPENDS_${PN} += "qtmultimedia \
+                   qtmultimedia-qmlplugins \
+                   agl-service-mediascanner"