cluster-receiver_git: Add cluster-receiver wayland depends
[AGL/meta-agl-cluster-demo.git] / recipes-demo-hmi / cluster-receiver / cluster-receiver_git.bb
index 92f9221..5d9fc9e 100644 (file)
@@ -14,13 +14,17 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS = "wayland wayland-ivi-extension libwindowmanager gstreamer1.0"
+DEPENDS += "wayland qtquickcontrols2 qtwebsockets libqtappfw gstreamer1.0\
+           gstreamer1.0-plugins-base gstreamer1.0-plugins-bad wayland-native\
+           wayland qtwayland qtwayland-native qtbase qtdeclarative qtquickcontrols2"
 
-inherit cmake aglwgt
+inherit cmake_qt5 pkgconfig aglwgt
 
 RDEPENDS_${PN} += " \
        gstreamer1.0-plugins-base \
        gstreamer1.0-plugins-good \
        gstreamer1.0-plugins-bad \
-       gstreamer1.0-vaapi \
 "
+
+# VA-API may be used on Intel if present
+RRECOMMENDS_${PN}_append_intel-corei7-64 = " gstreamer1.0-vaapi"