add recipes for identity, data persistence and nfc
[AGL/meta-agl-demo.git] / recipes-demo-hmi / agl-service-identity-agent / agl-service-identity-agent_git.bb
diff --git a/recipes-demo-hmi/agl-service-identity-agent/agl-service-identity-agent_git.bb b/recipes-demo-hmi/agl-service-identity-agent/agl-service-identity-agent_git.bb
new file mode 100644 (file)
index 0000000..5a41231
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "AGL identity agent binding"
+HOMEPAGE = "https://gitlab.com/iotbzh/aia-binding"
+SECTION = "base"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-identity-agent;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+PV = "1.0+git${SRCPV}"
+
+inherit cmake aglwgt pkgconfig
+
+S = "${WORKDIR}/git/agl-identity-service"
+
+DEPENDS = "curl af-binder json-c systemd"
+