Using the Tizen application manager to receive information about installed apps and...
[AGL/meta-agl-demo.git] / recipes-demo-hmi / HomeScreen / HomeScreen_0.2.0.bb
@@ -1,17 +1,22 @@
 SUMMARY     = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application + Home Screen Simulator + SampleAppTimeDate"
+DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderTizen + WindowManager + InputEventManager"
 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
-PV          = "0.1.1+gitr${SRCPV}"
+PV          = "0.2.0+gitr${SRCPV}"
 PR          = "r1"
 S           = "${WORKDIR}/git/"
 
 inherit qmake5
-DEPENDS = "qtbase"
+DEPENDS = " qtbase "
+
+# for HomeScreenAppFrameworkBinderTizen:
+DEPENDS += " pkgmgr-info aul "
+# for WindowManager:
+DEPENDS += " wayland-ivi-extension "
 
 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "3478f65b39560b333ba189e7d86e2c2cebfc9c7a"
+SRCREV  = "0a468d9b5ae7b3e5ba106facf17698d89b1ce200"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
 
 
@@ -24,9 +29,13 @@ do_install() {
     install -d ${D}/opt/AGL/${PN}
     install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
     install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
+    install -m 0755 ${B}/HomeScreenAppFrameworkBinderTizen/HomeScreenAppFrameworkBinderTizen ${D}/opt/AGL/${PN}/
+    install -m 0755 ${B}/WindowManager/WindowManager ${D}/opt/AGL/${PN}/
+    install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/opt/AGL/${PN}/
+
 
     install -d ${D}/opt/AGL/${PN}/colorschemes
-    cp ${B}/HomeScreen/colorschemes/* ${D}/opt/AGL/${PN}/colorschemes/
+    cp -r ${B}/HomeScreen/colorschemes/* ${D}/opt/AGL/${PN}/colorschemes/
 }
 
 FILES_${PN} += "/opt/AGL/${PN}/"