Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / settings / settings_git.bb
index 60cbdf5..84d830c 100644 (file)
@@ -3,29 +3,32 @@ DESCRIPTION = "AGL demonstration Settings application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0"
+LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = " \
-    libqtappfw \
+    qtbase \
+    qtdeclarative \
     qtquickcontrols2 \
-    qt-qrcode \
     qtvirtualkeyboard \
+    libqtappfw \
 "
 
-PV = "1.0+git${SRCPV}"
+PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV = "26dc6a8c8847248450bf902124b7cd867e027274"
 
 S  = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt
+inherit qmake5 pkgconfig
+
+FILES:${PN} += "${datadir}/icons/"
 
 RDEPENDS:${PN} += " \
-    qt-qrcode \
-    agl-service-bluetooth \
-    agl-service-network \
-    agl-service-voice-high \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+    qtquickcontrols2-agl-style \
     libqtappfw \
 "