Fix style issues in app recipes
[AGL/meta-agl-demo.git] / recipes-demo / settings / settings_git.bb
index 6486b03..24ab47a 100644 (file)
@@ -6,22 +6,26 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = " \
+    libqtappfw \
+    qtquickcontrols2 \
+    qt-qrcode \
+    libhomescreen \
+    qtvirtualkeyboard \
+"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "libqtappfw qtquickcontrols2 qt-qrcode"
-DEPENDS += "libhomescreen qtvirtualkeyboard"
+inherit qmake5 aglwgt
 
-# runtime dependencies
 RDEPENDS_${PN} += " \
-       qt-qrcode \
-       agl-service-bluetooth \
-       agl-service-network \
-       libqtappfw \
+    qt-qrcode \
+    agl-service-bluetooth \
+    agl-service-network \
+    libqtappfw \
 "
-
-inherit qmake5 aglwgt