Add now required pkgconfig inherit to restored app recipes
[AGL/meta-agl-demo.git] / recipes-demo / phone / phone_git.bb
index 41ca0e6..a5fa443 100644 (file)
@@ -6,12 +6,7 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = " \
-    qtquickcontrols2 \
-    libqtappfw \
-    libhomescreen \
-    gstreamer1.0 \
-"
+DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
 
 PV = "1.0+git${SRCPV}"
 
@@ -20,10 +15,8 @@ SRCREV  = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt
+inherit qmake5 pkgconfig
 
-RDEPENDS_${PN} += " \
-    agl-service-telephony \
-    agl-service-bluetooth-pbap \
-    libqtappfw \
-"
+FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
+
+RDEPENDS:${PN} += "libqtappfw"