Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / phone / phone_git.bb
index dd86722..61050bc 100644 (file)
@@ -6,19 +6,17 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
 
 PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            libqtappfw \
-            libhomescreen \
-            gstreamer1.0 \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "bfcc2fa194474a7bc317583072b62c977ae0fc14"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig
 
-inherit qmake5 aglwgt
+FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
 
-RDEPENDS_${PN} += "agl-service-telephony agl-service-bluetooth-pbap libqtappfw"
+RDEPENDS:${PN} += "libqtappfw"