Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / phone / phone_git.bb
index 41ca0e6..61050bc 100644 (file)
@@ -6,24 +6,17 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = " \
-    qtquickcontrols2 \
-    libqtappfw \
-    libhomescreen \
-    gstreamer1.0 \
-"
+DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
 
 PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "bfcc2fa194474a7bc317583072b62c977ae0fc14"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt
+inherit qmake5 pkgconfig
 
-RDEPENDS_${PN} += " \
-    agl-service-telephony \
-    agl-service-bluetooth-pbap \
-    libqtappfw \
-"
+FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
+
+RDEPENDS:${PN} += "libqtappfw"