agl-ivi-demo-platform-flutter: add ondemandnavi
[AGL/meta-agl-demo.git] / recipes-demo / navigation / tbtnavi_git.bb
index d2e8e63..b621381 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtL
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
+LICENSE = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
                     file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
@@ -11,26 +11,52 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
 "
 
-DEPENDS += "qtbase \
-            qtquickcontrols2 \
-            qlibhomescreen \
-            qtlocation \
-            libqtappfw \
-            wayland-native \
-            qtwayland-native \
+DEPENDS = " \
+    qtbase \
+    qtquickcontrols2 \
+    qtlocation \
+    libqtappfw \
+    qtwayland-native \
+    protobuf \
+    grpc \
+    grpc-native \
 "
 
-PV = "1.0+git${SRCPV}"
+PV = "2.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH} \
+           file://tbtnavi.service \
+           file://tbtnavi.conf \
+           file://tbtnavi.token \
+"
+SRCREV = "f00c1e19f5c4cbcd185c8043f3062612bf1537f7"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt pkgconfig
+inherit meson systemd pkgconfig
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
+do_install:append() {
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/tbtnavi
+    install -m 0644 ${WORKDIR}/tbtnavi.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
+}
 
-RDEPENDS_${PN} += "qtlocation \
-                   ondemandnavi-config \
-                   agl-service-navigation \
-                   libqtappfw \
+RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+    qtlocation \
+    ondemandnavi-config \
+    libqtappfw \
 "