Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / navigation / ondemandnavi_git.bb
index 79d96a0..c89ddeb 100644 (file)
@@ -6,23 +6,20 @@ SECTION     = "apps"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = " \
-    qtquickcontrols2 \
-    qlibhomescreen \
-    qtlocation \
-    libqtappfw \
-"
+DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
 
-PV = "1.0+git${SRCPV}"
+PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "1593664d2f17ab563c7ad81215696b1ac6a3bd7b"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt pkgconfig
+inherit qmake5 pkgconfig
 
-RDEPENDS_${PN} += " \
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += " \
     qtlocation \
     flite \
     libqtappfw \
@@ -30,6 +27,3 @@ RDEPENDS_${PN} += " \
     gstreamer1.0 \
     ondemandnavi-config \
 "
-
-RPROVIDES_${PN} = "virtual/navigation"
-