Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / launcher / launcher_git.bb
index 13d36ae..3c27fab 100644 (file)
@@ -1,6 +1,6 @@
 SUMMARY     = "AGL Launcher Application"
 DESCRIPTION = "AGL Launcher Application build with recipe method"
-HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/launcher"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
@@ -10,25 +10,38 @@ DEPENDS = "\
         qtdeclarative \
         qtquickcontrols2 \
         qtwebsockets \
-        qlibhomescreen \
         wayland-native \
         wayland \
         qtwayland \
         qtwayland-native \
+        agl-compositor \
+        json-c \
+        applaunchd \
 "
 
-# FIXME: launcher needs agl-shell-desktop, part of agl-compositor(-protocols) package
-DEPENDS_append = " agl-compositor"
-
 PV      = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRC_URI = " \
+        git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
+        file://launcher.service \
+        "
+SRCREV  = "fd578508fe8f59a0bf11916ea99561125dcfc4ba"
 
 S       = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig aglwgt
+inherit qmake5 systemd pkgconfig
+
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+do_install:append() {
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
+    ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+}
 
-RDEPENDS_${PN} = "agl-service-homescreen"
+FILES:${PN} += " ${systemd_user_unitdir}"
+
+RDEPENDS:${PN} += " \
+    applaunchd \
+    homescreen \
+"