Remove meta-python dependencies
[AGL/meta-agl-demo.git] / recipes-demo / html5-mixer / html5-mixer_git.bb
index b6b5814..fe45ef1 100644 (file)
@@ -11,21 +11,22 @@ B       = "${WORKDIR}/build"
 SRC_URI = " \
   git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
 "
-SRCREV = "c189320ab6810d4c916fa8f697a9452f3a8976a4"
+SRCREV = "e57fc753b3a083ddea52dbe4cd003261e836b2d4"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-mixer"
 AGL_APP_NAME = "HTML5 Mixer"
 
-DEPENDS = "nodejs-native"
+DEPENDS = "nodejs-native protobuf-native"
 
 do_compile[network] = "1"
 do_compile() {
   cd ${S}
   rm -rf package node_modules package-lock.json
   npm install
+  npm run generate-grpc
   npm run build
 }