html5-mediaplayer: recover HTML5 mediaplayer demo application.
[AGL/meta-agl-demo.git] / recipes-demo / html5-mediaplayer / html5-mediaplayer_git.bb
index ddb2ee2..4fd1df2 100644 (file)
@@ -1,4 +1,4 @@
-SUMMARY     = "AGL HTML5 Mediaplayer Application"
+SUMMARY     = "AGL HTML5 media player Application"
 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-mediaplayer/"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
@@ -6,10 +6,37 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git"
+B       = "${WORKDIR}/build"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRC_URI = " \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=master \
+  file://webapps-mediaplayer.desktop \
+"
+SRCREV = "07adebd03e37a790462f80b6f3bb001bad7e6748"
+
+inherit pythonnative
 
 DEPENDS = "nodejs-native"
 
-inherit aglwgt
+do_compile[network] = "1"
+do_compile() {
+  cd ${S}
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+  install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/webapps-mediaplayer.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+  ${WAM_APPLICATIONS_DIR}/${PN} \
+  ${APPLICATIONS_DIR} \
+"