html5-launcher_git: Remove autobuild script builds
[AGL/meta-agl-demo.git] / recipes-demo / html5-launcher / html5-launcher_git.bb
index 2a4f7ed..5c70fd7 100644 (file)
@@ -10,31 +10,33 @@ B       = "${WORKDIR}/build"
 
 SRC_URI = " \
   git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
-  file://launcher.service \
+  file://launcher.desktop \
 "
 SRCREV = "${AGL_APP_REVISION}"
 
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
 
 do_install() {
   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-  install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
-  install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
-  ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
 }
 
 FILES_${PN} = " \
   ${WAM_APPLICATIONS_DIR}/${PN} \
-  ${systemd_user_unitdir} \
+  ${APPLICATIONS_DIR} \
 "
 
 RCONFLICTS_${PN} = "launcher"
+RDEPENDS_${PN} = "applaunchd"