wam, chromium, html5-*: improve initial frame, and drop usage of config.xml
[AGL/meta-agl-demo.git] / recipes-demo / html5-hvac / html5-hvac_git.bb
index 85fed29..f0106db 100644 (file)
@@ -9,17 +9,18 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH} \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
   file://webapps-hvac.desktop \
 "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "e64d69bdad0bb302900ec631b54ad6b6d6dcbacd"
 
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -35,4 +36,4 @@ do_install() {
 FILES_${PN} = " \
   ${WAM_APPLICATIONS_DIR}/${PN} \
   ${APPLICATIONS_DIR} \
-"
\ No newline at end of file
+"