Remove meta-python dependencies
[AGL/meta-agl-demo.git] / recipes-demo / html5-hvac / html5-hvac_git.bb
index 79a144b..c0d4c54 100644 (file)
@@ -11,21 +11,22 @@ B       = "${WORKDIR}/build"
 SRC_URI = " \
   git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
 "
-SRCREV = "b0c869c0461741413af9e6a24f6e156717b6362f"
+SRCREV = "c323ab8fde212120d8d1914d453afeb55b3576e5"
 
-inherit pythonnative agl-app
+inherit agl-app
 
 AGL_APP_TEMPLATE = "agl-app-web"
 AGL_APP_ID = "webapps-hvac"
 AGL_APP_NAME = "HTML5 HVAC"
 
-DEPENDS = "nodejs-native"
+DEPENDS = "nodejs-native protobuf-native"
 
 do_compile[network] = "1"
 do_compile() {
   cd ${S}
   rm -rf package node_modules package-lock.json
   npm install
+  npm run generate-grpc
   npm run build
 }