html5-hvac_git: Remove autobuild script builds
[AGL/meta-agl-demo.git] / recipes-demo / html5-hvac / html5-hvac_git.bb
index 85fed29..16bf739 100644 (file)
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -35,4 +36,4 @@ do_install() {
 FILES_${PN} = " \
   ${WAM_APPLICATIONS_DIR}/${PN} \
   ${APPLICATIONS_DIR} \
-"
\ No newline at end of file
+"