Remove meta-python dependencies
[AGL/meta-agl-demo.git] / recipes-demo / html5-background / html5-background_git.bb
index 798417b..c848710 100644 (file)
@@ -1,4 +1,4 @@
-SUMMARY     = "AGL HTML5 Homescreen"
+SUMMARY     = "AGL HTML5 Background"
 HOMEPAGE    = "https://github.com/AGL-web-applications/background"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
@@ -9,13 +9,19 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://github.com/AGL-web-applications/background.git;protocol=https;branch=master \
-  file://webapps-html5-background.desktop \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-background;protocol=https;branch=master \
 "
-SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
+SRCREV = "aa7e2a81e91ed076c0bc9ba07db5aee0f34668df"
+
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-${BPN}"
+AGL_APP_NAME = "HTML5 Background"
 
 DEPENDS = "nodejs-native"
 
+do_compile[network] = "1"
 do_compile() {
   cd ${S}
   rm -rf package node_modules package-lock.json
@@ -23,19 +29,13 @@ do_compile() {
   npm run build
 }
 
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
 
 do_install() {
   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-  install -d ${D}${APPLICATIONS_DIR}
-  install ${WORKDIR}/webapps-html5-background.desktop ${D}${APPLICATIONS_DIR}
 }
 
-FILES_${PN} = " \
-  ${WAM_APPLICATIONS_DIR}/${PN} \
-  ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
 
-RCONFLICTS_${PN} = "homescreen"
+RCONFLICTS:${PN} = "homescreen"