wam, chromium, html5-*: improve initial frame, and drop usage of config.xml
[AGL/meta-agl-demo.git] / recipes-demo / html5-background / html5-background_git.bb
index cf1dee1..792b04a 100644 (file)
@@ -1,4 +1,4 @@
-SUMMARY     = "AGL HTML5 Homescreen"
+SUMMARY     = "AGL HTML5 Background"
 HOMEPAGE    = "https://github.com/AGL-web-applications/background"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
@@ -9,17 +9,18 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://github.com/AGL-web-applications/background.git;protocol=https;branch=master \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-background;protocol=https;branch=master \
   file://webapps-html5-background.desktop \
 "
-SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
+SRCREV = "7b796408f4ee1ca1b92a02445513d939079af46e"
 
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"