Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index b53519e..d21711c 100644 (file)
@@ -4,27 +4,28 @@ HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-#LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 DEPENDS = " \
     qtbase \
     qtdeclarative \
     qtquickcontrols2 \
+    libqtappfw \
     wayland-native \
     wayland \
     qtwayland \
     qtwayland-native \
     agl-compositor \
-    json-c \
-    qtwebsockets \
+    applaunchd \
 "
 
-PV      = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;nobranch=1"
-SRCREV  = "09b5eb1b42910e84612a37a0fb44629c73eee3e7"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
+           file://homescreen.service \
+"
+SRCREV = "c35327b02a28a83536450a664326d183662e89e1"
 
-S       = "${WORKDIR}/git"
+S = "${WORKDIR}/git"
 
 inherit qmake5 systemd pkgconfig
 
@@ -32,10 +33,18 @@ PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
-
 do_install:append() {
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
+    ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+}
 
-    install -d ${D}/${bindir}
-    install -m 0644 ${B}/homescreen/HomeScreen ${D}/${bindir}/homescreen
+FILES:${PN} += " ${systemd_user_unitdir}"
 
-}
\ No newline at end of file
+RDEPENDS:${PN} += " \
+    libqtappfw \
+    applaunchd \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+"