Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index 7e49ad9..d21711c 100644 (file)
@@ -10,36 +10,41 @@ DEPENDS = " \
     qtdeclarative \
     qtquickcontrols2 \
     libqtappfw \
-    libhomescreen \
-    libafb-helpers-qt \
     wayland-native \
     wayland \
     qtwayland \
     qtwayland-native \
+    agl-compositor \
+    applaunchd \
 "
 
-# FIXME: homescreen needs agl-shell-desktop, part of agl-compositor(-protocols) package
-DEPENDS_append = " agl-compositor"
+PV = "1.0+git${SRCPV}"
 
-PV      = "1.0+git${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
+           file://homescreen.service \
+"
+SRCREV = "c35327b02a28a83536450a664326d183662e89e1"
+
+S = "${WORKDIR}/git"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+inherit qmake5 systemd pkgconfig
 
-S       = "${WORKDIR}/git"
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
-inherit qmake5 systemd pkgconfig aglwgt
+OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+do_install:append() {
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
+    ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+}
 
-OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+FILES:${PN} += " ${systemd_user_unitdir}"
 
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
     libqtappfw \
-    agl-service-audiomixer \
-    agl-service-bluetooth \
-    agl-service-homescreen \
-    agl-service-network \
-    agl-service-weather \
-    agl-service-voice-high \
+    applaunchd \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
 "