Fix S definitions in various recipes
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index 2940378..1ec938b 100644 (file)
@@ -9,8 +9,6 @@ DEPENDS = " \
     qtbase \
     qtdeclarative \
     qtquickcontrols2 \
-    agl-service-homescreen \
-    agl-service-weather \
     libqtappfw \
     libhomescreen \
     libafb-helpers-qt \
@@ -25,7 +23,7 @@ PV      = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
 inherit qmake5 systemd pkgconfig aglwgt
 
@@ -35,4 +33,10 @@ OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel'
 
 RDEPENDS_${PN} += " \
     libqtappfw \
+    agl-service-audiomixer \
+    agl-service-bluetooth \
+    agl-service-homescreen \
+    agl-service-network \
+    agl-service-weather \
+    agl-service-voice-high \
 "