Remove meta-python dependencies
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / qt-cluster-receiver_git.bb
index 80f8edb..d50e9dd 100644 (file)
@@ -1,5 +1,5 @@
-SUMMARY     = "Instrument Cluster Receiver AGL Demonstration"
-DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster remote display"
+SUMMARY     = "Instrument Cluster receiver application"
+DESCRIPTION = "AGL demonstration instrument cluster Qt remote display application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/agl-qt-cluster-demo-receiver"
 SECTION     = "apps"
 
@@ -16,15 +16,26 @@ DEPENDS = " \
 
 PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH} \
+           file://qt-cluster-receiver.service \
+"
+SRCREV  = "b5622ce91307589b03ad5d903214b47ff2277e48"
 
 S  = "${WORKDIR}/git"
 
-inherit cmake_qt5 pkgconfig aglwgt
+inherit cmake_qt5 pkgconfig systemd
+
+do_install:append() {
+    # Only install unit, do not enable it by default
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+}
 
 RDEPENDS:${PN} += " \
+    qtwayland \
     gstreamer1.0-plugins-base \
     gstreamer1.0-plugins-good \
     gstreamer1.0-plugins-bad \
 "
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"