Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / cluster-receiver_git.bb
index b2a4640..c022212 100644 (file)
@@ -1,5 +1,5 @@
-SUMMARY     = "Instrument Cluster Receiver application"
-DESCRIPTION = "AGL demonstration instrument cluster remote display application"
+SUMMARY     = "Instrument Cluster receiver application"
+DESCRIPTION = "AGL demonstration instrument cluster XDG remote display application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
 SECTION     = "apps"
 
@@ -8,22 +8,30 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
 
 DEPENDS = " \
     wayland wayland-native \
+    agl-compositor \
     gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
 "
 
-# FIXME: cluster-receiver needs agl-shell-desktop, part of agl-compositor(-protocols) package
-DEPENDS_append = " agl-compositor"
-
 PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH} \
+           file://cluster-receiver.service \
+"
+SRCREV  = "be95c2a9466d03dda01cb882a70458aac81f36e4"
 
 S  = "${WORKDIR}/git"
 
-inherit cmake pkgconfig aglwgt
+inherit cmake pkgconfig
+
+do_install:append() {
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+}
+
+FILES:${PN} += " ${systemd_user_unitdir}"
 
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
     gstreamer1.0-plugins-base \
     gstreamer1.0-plugins-good \
     gstreamer1.0-plugins-bad \