unicens-config: Add bash to rdeps
[AGL/meta-agl-demo.git] / recipes-config / unicens-config / unicens-config.bb
index e8f5b78..f33ffb2 100644 (file)
@@ -2,11 +2,14 @@ DESCRIPTION = "Configure MOST driver"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
+RDEPENDS_${PN} = "bash"
+
 SRC_URI = "\
     file://unicens-config.service \
     file://unicens-config.sh \
 "
 
+
 inherit systemd
 
 SYSTEMD_PACKAGES = "${PN}"
@@ -21,7 +24,7 @@ do_compile() {
 
 do_install() {
     install -d ${D}${systemd_system_unitdir}
-    install -m 0755 ${WORKDIR}/unicens-config.service ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/unicens-config.service ${D}${systemd_system_unitdir}
     install -d ${D}${bindir}
     install -m 0755 ${WORKDIR}/unicens-config.sh ${D}${bindir}
 }