af-platform-setup: Add recipe for setting platform
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-platform-setup / af-platform-setup_1.0.bb
diff --git a/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb b/meta-app-framework/recipes-core/af-platform-setup/af-platform-setup_1.0.bb
new file mode 100644 (file)
index 0000000..0963875
--- /dev/null
@@ -0,0 +1,16 @@
+HOMEPAGE = "here"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://udev-shared.conf"
+
+S = "${WORKDIR}"
+
+do_install() {
+       d=${D}${systemd_system_unitdir}/systemd-udevd.service.d
+       install -d $d
+       install ${S}/udev-shared.conf $d
+}
+
+FILES_${PN} = "${systemd_system_unitdir}"