meta-app-framework: add af-main-tools and dependencies in nativesdk-packagegroup...
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / af-main_1.0.bb
index a29b071..75cdcc3 100644 (file)
@@ -1,3 +1,5 @@
+require af-main_${PV}.inc 
+
 # NOTE: using libcap-native and setcap in install doesn't work
 # NOTE: there is no SYSTEMD_USER_SERVICE_...
 # NOTE: maybe setting afm_name to agl-framework is cleaner but has implications
@@ -6,38 +8,19 @@
 
 inherit cmake pkgconfig useradd systemd
 
-SUMMARY = "AGL Framework Main part"
-DESCRIPTION = "\
-This is a core framework component for managing \
-applications, widgets, and components. \
-"
-
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-main"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=1.0"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
-           ${SRC_URI_files} \
-          "
-
-SRCREV = "d0fdae3af6998efdce4c6ba0c5d650898c9c5b27"
-
 SECTION = "base"
 
-S = "${WORKDIR}/git"
-
 DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c security-manager libcap-native af-binder"
 
 afm_name    = "afm"
 afm_confdir = "${sysconfdir}/${afm_name}"
 afm_datadir = "${datadir}/${afm_name}"
-afb_plugin_dir = "${libdir}/afb"
+afb_binding_dir = "${libdir}/afb"
 
 EXTRA_OECMAKE = "\
        -DUSE_LIBZIP=1 \
        -DUSE_SIMULATION=0 \
+       -DUSE_SDK=0 \
        -Dafm_name=${afm_name} \
        -Dafm_confdir=${afm_confdir} \
        -Dafm_datadir=${afm_datadir} \
@@ -83,13 +66,11 @@ pkg_postinst_${PN}_smack() {
     setcap cap_mac_override,cap_mac_admin,cap_setgid=ie $D${bindir}/afm-user-daemon
 }
 
-PACKAGES =+ "${PN}-afbplugin ${PN}-afbplugin-dbg"
-FILES_${PN}-afbplugin = " ${afb_plugin_dir}/afm-main-plugin.so "
-FILES_${PN}-afbplugin-dbg = " ${afb_plugin_dir}/.debug/afm-main-plugin.so "
+PACKAGES =+ "${PN}-binding ${PN}-binding-dbg"
+FILES_${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
+FILES_${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
 
 PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
 FILES_${PN}-tools = "${bindir}/wgtpkg-*"
 FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
 
-BBCLASSEXTEND = "native nativesdk"
-