meta-agl-profile-core: add pyagl to agl-devel images
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / pyagl / pyagl_git.bb
diff --git a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
new file mode 100644 (file)
index 0000000..770fdac
--- /dev/null
@@ -0,0 +1,29 @@
+SUMMARY = "Python bindings and tests for Automotive Grade Linux services"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/pyagl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "f583233db298a709a813d8c0af97769ba30ae002"
+PV = "${AGL_BRANCH}+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += " \
+    python3-asyncio \
+    python3-asyncssh \
+    python3-core \
+    python3-json \
+    python3-logging \
+    python3-math \
+    python3-parse \
+    python3-pprint \
+    python3-pytest \
+    python3-pytest-asyncio \
+    python3-pytest-dependency \
+    python3-pytest-reverse \
+    python3-typing \
+    python3-websockets \
+"