meta-agl-core: add recipe for librba and rba-config
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / rba / librba_1.0.bb
diff --git a/meta-agl-core/recipes-graphics/rba/librba_1.0.bb b/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
new file mode 100644 (file)
index 0000000..450684f
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "RBA"
+DESCRIPTION = "Rule Based Arbitrator decides which of the content to display \
+when a large number of contents to be displayed on the cockpit display device \
+(CID, meter, HUD, etc.) occur simultaneously under a certain rule (arbitration)"
+
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=13afa517927767fe9b7a65818a02bd8f"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/rba;protocol=https;branch=master"
+SRCREV = "2cfe2c611be63ae4541abf4e13cfecff0f008f25"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake
+
+FILES_${PN} = "${libdir}/"
+FILES_${PN}-dev = "${libdir}/pkgconfig/librba.pc \
+                   ${includedir}/ \
+                  "
+INSANE_SKIP_${PN} += "dev-so"
+INSANE_SKIP_${PN}-dev += "dev-elf"