Add uvc.cfg for usb video class kernel configure
[AGL/meta-agl.git] / meta-agl-bsp / meta-ti / recipes-kernel / linux / linux-ti-staging_%.bbappend
index c5fca45..f9c0c04 100644 (file)
@@ -19,9 +19,18 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/btusb.cfg"
 # smack patches for handling bluetooth
 
 SRC_URI_append_smack = "\
-       file://0001-Smack-File-receive-for-sockets.patch \
-       file://0002-smack-fix-cache-of-access-labels.patch \
-       file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
        file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
 "
 
+# Enable support for smack
+KERNEL_CONFIG_FRAGMENTS_append_smack = "\
+       ${WORKDIR}/audit.cfg \
+       ${WORKDIR}/smack.cfg \
+       ${WORKDIR}/smack-default-lsm.cfg \
+"
+
+# file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"