Add joystick.cfg for usb joystick and steering-wheel kernel configure
[AGL/meta-agl.git] / meta-agl-bsp / meta-renesas / recipes-kernel / linux / linux-renesas_%.bbappend
index 35b2253..8776a84 100755 (executable)
@@ -32,7 +32,19 @@ SRC_URI_append_agl-porter-hibernate = " file://hibernation/0001-Add-Hibernation-
                                         file://hibernation/0013-Add-rcar-spi-hibernation-code.patch \
                                         file://hibernation/0014-Add-rcar-sci-hibernation-code.patch \ 
                                         file://hibernation/0015-Add-rcar-usbphy-hibernation-code.patch \
+                                        file://hibernation/0001-Add-shdmac-hibernation-code.patch \
+                                        file://hibernation/0002-Fix-Black-blink-correction-of-display.patch \
+                                        file://hibernation/0003-Add-hibernation-image-area.patch \
                                         file://hibernation/hibernation.cfg \
                                        "
 
 KERNEL_CONFIG_FRAGMENTS_append_agl-porter-hibernate += " ${WORKDIR}/hibernation/hibernation.cfg"
+
+# file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"