meta-agl-bsp: add fix for intermittent failures in arm-trusted-firmware
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-bsp / arm-trusted-firmware / arm-trusted-firmware_git.bbappend
index 4ba36ca..212c661 100644 (file)
@@ -3,3 +3,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 SRC_URI:append = " \
     file://0001-Boot-Normal-World-in-EL2.patch \
 "
+
+do_ipl_opt_deploy:prepend () {
+    # Work around bug in BSP recipe, it can fail if nothing else has
+    # happened to run first and create the directory.
+    install -d ${DEPLOY_DIR_IMAGE}
+}