Add joystick.cfg for usb joystick and steering-wheel kernel configure
[AGL/meta-agl.git] / meta-agl-bsp / meta-qcom / recipes-kernel / linux / linux-linaro-qcomlt_4.9.bbappend
index 80fe23b..8897805 100644 (file)
@@ -5,13 +5,6 @@ SRC_URI_append_smack = "\
        file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
 "
 
-# Fix CVE-2017-1000364 by backporting the patches from upstream for 4.9
-SRC_URI_append = "\
-       file://0001-mm-larger-stack-guard-gap-between-vmas.patch \
-       file://0002-Allow-stack-to-grow-up-to-address-space-limit.patch \
-       file://0003-mm-fix-new-crash-in-unmapped_area_topdown.patch \
-"
-
 # Extra configuration options
 SRC_URI += "file://fanotify.cfg \
             file://uinput.cfg \
@@ -35,3 +28,9 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
 
 # file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"