Update Flutter demo images
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-flutter.bb
1 SUMMARY = "The software for Flutter Demo platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages for AGL Flutter Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-flutter \
11     "
12
13 RDEPENDS:${PN} += "\
14     packagegroup-agl-image-ivi \
15     packagegroup-agl-profile-graphical-qt5 \
16     packagegroup-agl-demo \
17     "
18
19 AGL_FLUTTER_RUNTIME ?= "runtimerelease"
20
21 AGL_APPS = " \
22     flutter-dashboard-${AGL_FLUTTER_RUNTIME} \ \
23     flutter-hvac-${AGL_FLUTTER_RUNTIME} \ \
24     ondemandnavi \
25     settings \
26     mediaplayer \
27     messaging \
28     phone \
29     radio \
30     "
31
32 RDEPENDS:${PN}:append = " \
33     agl-compositor \
34     flutter-auto-${AGL_FLUTTER_RUNTIME} \
35     flutter-homescreen-${AGL_FLUTTER_RUNTIME} \
36     qtquickcontrols2-agl \
37     qtquickcontrols2-agl-style \
38     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
39     ${AGL_APPS} \
40     psplash-portrait-config \
41     "