Change SRC_URI and SRCREV for ivi-demo-flutter-apps
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-flutter.bb
1 SUMMARY = "The software for Flutter Demo platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages for AGL Flutter Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-flutter \
11     "
12
13 RDEPENDS:${PN} += "\
14     packagegroup-agl-image-ivi \
15     packagegroup-agl-profile-graphical-qt5 \
16     packagegroup-hmi-framework \
17     packagegroup-agl-demo \
18     "
19
20 AGL_APPS = " \
21     hvac \
22     dashboard \
23     flutter-dashboard \
24     flutter-hvac \
25     flutter-nav \
26     flutter-mediaplayer \
27     "
28
29 RDEPENDS:${PN}:append = " \
30     flutter-auto-runtimerelease \
31     launcher \
32     qtquickcontrols2-agl \
33     qtquickcontrols2-agl-style \
34     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
35     ${AGL_APPS} \
36     psplash-portrait-config \
37     "