Add support for CAN driven speeds for the demo dashboard
[AGL/meta-agl-cluster-demo.git] / recipes-platform / packagegroups / packagegroup-agl-cluster-demo-qtcompositor.bb
1 SUMMARY = "The software for AGL Cluster Demo Qtwayland Compositor"
2 DESCRIPTION = "A set of packages belong to AGL Cluster Demo Qtwayland Compositor"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-cluster-demo-qtcompositor \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-profile-cluster-qtcompositor \
16     packagegroup-agl-ttf-fonts \
17     packagegroup-agl-networking \
18     "
19
20 AGL_SERVICE = " \
21     agl-service-bluetooth \
22     agl-service-can-low-level \
23     agl-service-data-persistence \
24     agl-service-gps \
25     agl-service-network \
26     agl-service-unicens \
27     agl-service-hvac \
28     agl-service-nfc \
29     agl-service-identity-agent \
30     "
31
32 SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
33     'sdl-core', '', d)}"
34
35
36 AGL_APPS = " \
37     cluster-gauges-qtcompositor \
38     "
39
40 RDEPENDS_${PN}_append = " \
41     libva-utils \
42     linux-firmware-ralink \
43     can-utils \
44     most \
45     ${AGL_SERVICE} \
46     ${AGL_APPS} \
47     ${SMARTDEVICELINK} \
48 "