Add a shrink agl-demo-platform version
[AGL/meta-agl-cluster-demo.git] / recipes-platform / packagegroups / packagegroup-agl-cluster-demo-qtcompositor.bb
1 SUMMARY = "The software for AGL Cluster Demo Qtwayland Compositor"
2 DESCRIPTION = "A set of packages belong to AGL Cluster Demo Qtwayland Compositor"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-cluster-demo-qtcompositor \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-profile-cluster-qtcompositor \
16     "
17
18 AGL_SERVICE = " \
19     agl-service-bluetooth \
20     agl-service-can-low-level \
21     agl-service-data-persistence \
22     agl-service-gps \
23     agl-service-network \
24     agl-service-unicens \
25     agl-service-hvac \
26     agl-service-nfc \
27     agl-service-identity-agent \
28     "
29
30 SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
31     'sdl-core', '', d)}"
32
33 # fonts
34 TTF_FONTS = " \
35     ttf-bitstream-vera \
36     ttf-dejavu-sans \
37     ttf-dejavu-sans-mono \
38     ttf-dejavu-serif \
39     "
40
41 AGL_APPS = " \
42     cluster-gauges-qtcompositor \
43     "
44
45 RDEPENDS_${PN}_append = " \
46     libva-utils \
47     linux-firmware-ralink \
48     connman \
49     connman-client \
50     connman-tools \
51     cluster-connman-conf \
52     iproute2 \
53     dhcp-client \
54     can-utils \
55     most \
56     ${TTF_FONTS} \
57     ${AGL_SERVICE} \
58     ${AGL_APPS} \
59     ${SMARTDEVICELINK} \
60 "