weston-terminal-conf: add systemd-sandboxed demo configuration
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston-terminal-conf.bb
1 SUMMARY = "AGL user session"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
5 SRC_URI = " \
6     file://org.freedesktop.weston.wayland-terminal.desktop \
7     file://weston-terminal.desktop \
8 "
9
10 inherit allarch
11
12 do_install() {
13     install -d ${D}${datadir}/applications
14     install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
15
16     # Enable systemd sandboxing override as a demonstration
17     mkdir -p ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
18     ln -sf ${sysconfdir}/systemd/sandboxing/no-network.conf ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
19
20     # HACK - install .desktop file for systemd until applaunchd can do enumeration with homescreen names and icons
21     install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications/
22 }
23
24 FILES:${PN} = " \
25     ${datadir}/applications \
26     ${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d \
27 "
28
29 RDEPENDS:${PN} = " \
30     weston \
31 "