homescreen: Fix offscreen navigation guide
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
1 SUMMARY     = "AGL Home Screen Application"
2 DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager"
3 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
11            file://0001-Hack-to-resolve-the-media-player-doesn-t-play-next.patch \
12            file://fix-offscreen-navi-gid.patch \
13            file://homescreen.pc.in \
14            file://dbus-homescreen.conf.in"
15 SRCREV  = "${AUTOREV}"
16
17 # Pinned SRCREV for Charming Chinook, staging projects do not follow release branches
18 SRCREV_chinook = "3b5d0701a25b19ee2ac91d7466652c8fc4025db0"
19
20
21 # PV needs to be modified with SRCPV to work AUTOREV correctly
22 PV = "0.0+git${SRCPV}"
23 # git repository used
24 S           = "${WORKDIR}/git/"
25
26 DEPENDS += " qtbase "
27 # for HomeScreenAppFrameworkBinderTizen:
28 #DEPENDS += " pkgmgr-info aul "
29 # for WindowManager:
30 DEPENDS += " wayland-ivi-extension "
31 # for libhomescreen
32 DEPENDS += " glib-2.0 "
33 # for sample apps
34 DEPENDS += " qtdeclarative qtquickcontrols2 "
35
36
37 inherit qmake5 systemd pkgconfig
38
39
40 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
41
42 do_install() {
43     install -d ${D}/usr/AGL/${PN}
44     install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/usr/AGL/${PN}/
45     install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/usr/AGL/${PN}/
46     install -m 0755 ${B}/SampleHomeScreenInterfaceApp/SampleHomeScreenInterfaceApp ${D}/usr/AGL/${PN}/
47     install -m 0755 ${B}/HomeScreenAppFrameworkBinderAGL/HomeScreenAppFrameworkBinderAGL ${D}/usr/AGL/${PN}/
48     install -m 0755 ${B}/WindowManager/WindowManager ${D}/usr/AGL/${PN}/
49     install -m 0755 ${B}/InputEventManager/InputEventManager ${D}/usr/AGL/${PN}/
50     
51     install -d ${D}${libdir}
52     install -m 0644 ${B}/libhomescreen/libhomescreen.so.1.0.0 ${D}${libdir}/
53     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so
54     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
55     ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
56
57 # claneys: add dbus policy to make wifi/bluetooth status icon working as quick 
58 # workaround. (jira.automotivelinux.org : SPEC-377)
59     install -d ${D}/etc/dbus-1/session.d
60     install -m 0644 ${WORKDIR}/dbus-homescreen.conf.in ${D}/etc/dbus-1/session.d/homescreen.conf
61
62 # kooltux: still some problem with paths inside .pc file
63 # error at build time:
64 # ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/homescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
65 #
66     install -d ${D}${libdir}/pkgconfig
67     install -m 0644 ${WORKDIR}/homescreen.pc.in ${D}${libdir}/pkgconfig/homescreen.pc
68     sed -i s:OEPREFIX:${prefix}:g ${D}${libdir}/pkgconfig/homescreen.pc
69     sed -i s:OELIBDIR:${libdir}:g ${D}${libdir}/pkgconfig/homescreen.pc
70     sed -i s:OEINCDIR:${includedir}:g ${D}${libdir}/pkgconfig/homescreen.pc
71
72         install -d ${D}${includedir}
73         install -m 0644 ${S}/libhomescreen/include/libhomescreen.hpp ${D}${includedir}/
74
75     install -d ${D}${systemd_user_unitdir}
76     install -m 0644 ${S}/HomeScreen/conf/HomeScreen.service ${D}${systemd_user_unitdir}
77     install -m 0644 ${S}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_user_unitdir}
78     install -m 0644 ${S}/InputEventManager/conf/InputEventManager.service ${D}${systemd_user_unitdir}
79     install -m 0644 ${S}/WindowManager/conf/WindowManager.service ${D}${systemd_user_unitdir}
80
81     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
82     ln -sf ${systemd_user_unitdir}/WindowManager.service ${D}${sysconfdir}/systemd/user/default.target.wants
83     ln -sf ${systemd_user_unitdir}/HomeScreen.service ${D}${sysconfdir}/systemd/user/default.target.wants
84 }
85
86 FILES_${PN} += "/usr/AGL/${PN}/ ${libdir} ${systemd_user_unitdir}"
87 FILES_${PN}-dbg += "/usr/AGL/${PN}/.debug"
88
89
90 PACKAGES =+ "libhomescreen libhomescreen-dev libhomescreen-dbg"
91
92 FILES_libhomescreen = "\
93         ${libdir}/libhomescreen.so.* \
94 "
95 FILES_libhomescreen-dev = "\
96         ${includedir}/libhomescreen.hpp \
97         ${libdir}/libhomescreen.so \
98         ${libdir}/pkgconfig/homescreen.pc \
99 "
100 FILES_libhomescreen-dbg = "\
101         ${libdir}/.debug/libhomescreen.so.* \
102 "
103 RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
104
105 RDEPENDS_${PN}-dev += "libhomescreen-dev"
106
107
108 BBCLASSEXTEND = " nativesdk"