cluster-receiver: just RRECOMMEND gstreamer-vaapi for Intel
[AGL/meta-agl-cluster-demo.git] / recipes-demo-hmi / cluster-receiver / cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster Receiver AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster remote display"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
8                     file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
9
10 SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
11 SRCREV  = "${AGL_APP_REVISION}"
12
13 PV = "1.0+git${SRCPV}"
14 S  = "${WORKDIR}/git"
15
16 # build-time dependencies
17 DEPENDS = "wayland wayland-ivi-extension libwindowmanager gstreamer1.0"
18
19 inherit cmake aglwgt
20
21 RDEPENDS_${PN} += " \
22         gstreamer1.0-plugins-base \
23         gstreamer1.0-plugins-good \
24         gstreamer1.0-plugins-bad \
25 "
26
27 # VA-API may be used on Intel if present
28 RRECOMMENDS_${PN}_append_intel-corei7-64 = " gstreamer1.0-vaapi"