Fix Qt dependency of the CES demo.
[AGL/meta-agl-demo.git] / recipes-demo-hmi / CES2016-demo / CES2016-demo.bb
1 SUMMARY     = "Homescreen for the AGL Demonstrator @ CES2016"
2 DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CES2016"
3 HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2016"
4
5 SECTION     = "apps"
6
7 LICENSE     = "MPL-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
9
10 SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
11 SRCREV      = "AUTOINC"
12
13 RDEPENDS_${PN} += " \
14     qtmultimedia-qmlplugins \
15     qtquickcontrols-qmlplugins \
16     qtsvg-plugins \
17     "
18
19 # custom configure and install as these are just qml files
20
21 # we work in the git checkout ...
22 S = "${WORKDIR}/git"
23
24 do_configure() {
25     ls
26 }
27
28 # plain copy in own folder for now
29 do_install() {
30     mkdir -p ${D}/opt/AGL/CES2016/
31     cp -ar ./* ${D}/opt/AGL/CES2016/
32 }
33
34 FILES_${PN} = "/opt/AGL/"