recipes-demo: Add videoplayer recipe.
[AGL/meta-agl-demo.git] / recipes-demo / videoplayer / videoplayer_git.bb
1 SUMMARY     = "Video Player for AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating Media Player on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/videoplayer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/videoplayer;protocol=https;nobranch=1"
10 SRCREV = "2f4d09aec6531c64356a52255bcfaf8df7c4f3e4"
11
12 PV = "1.0+git${SRCPV}"
13 S  = "${WORKDIR}/git"
14
15 # build-time dependencies
16 DEPENDS += " \
17     qtquickcontrols2 \
18     libqtappfw \
19     qtmultimedia \
20 "
21
22 inherit qmake5 agl-app
23
24 AGL_APP_NAME = "Video"
25
26 RDEPENDS:${PN} += " \
27     qtmultimedia \
28     qtmultimedia-qmlplugins \
29 "
30
31 FILES:${PN} += "${datadir}/icons"