Fix style issues in app recipes
[AGL/meta-agl-demo.git] / recipes-demo / navigation / ondemandnavi_git.bb
1 SUMMARY     = "Navigation application."
2 DESCRIPTION = "AGL demonstration Navigation application based on QtLocation widget."
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtquickcontrols2 \
11     qlibhomescreen \
12     qtlocation \
13     libqtappfw \
14 "
15
16 PV = "1.0+git${SRCPV}"
17
18 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
19 SRCREV = "${AGL_APP_REVISION}"
20
21 S = "${WORKDIR}/git"
22
23 inherit qmake5 aglwgt pkgconfig
24
25 RDEPENDS_${PN} += " \
26     qtlocation \
27     flite \
28     libqtappfw \
29     openjtalk \
30     gstreamer1.0 \
31     ondemandnavi-config \
32 "
33
34 RPROVIDES_${PN} = "virtual/navigation"
35