homescreen: convert to using the new App FW
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
1 SUMMARY     = "Home Screen application"
2 DESCRIPTION = "AGL demonstration Home Screen application"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     qtbase \
10     qtdeclarative \
11     qtquickcontrols2 \
12     wayland-native \
13     wayland \
14     qtwayland \
15     qtwayland-native \
16     agl-compositor \
17     applaunchd \
18 "
19
20 PV = "1.0+git${SRCPV}"
21
22 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
23            file://homescreen.service \
24 "
25 SRCREV = "${AGL_APP_REVISION}"
26
27 S = "${WORKDIR}/git"
28
29 inherit qmake5 systemd pkgconfig
30
31 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
32
33 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
34
35 do_install:append() {
36     install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
37     install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
38     ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
39 }
40
41 FILES:${PN} += " ${systemd_user_unitdir}"
42
43 RDEPENDS:${PN} += " \
44     applaunchd \
45     qtwayland \
46     qtbase-qmlplugins \
47     qtgraphicaleffects-qmlplugins \
48 "