Fix meta-netboot build on Minnowboard Max after migration to Krogoth
[AGL/meta-agl.git] / meta-netboot / classes / netboot.bbclass
1 # Enable network bootable image and initrd/initramfs
2
3 # add image classes for uboot
4 IMAGE_CLASSES += "${@'image_types_uboot' if (d.getVar("KERNEL_IMAGETYPE", True) == "uImage") else ''}"
5
6 python () {
7         d.appendVar("IMAGE_FSTYPES"," ext4")
8
9         if (bb.utils.contains("IMAGE_FSTYPES","live",True,False,d)):
10                 # typical case for Minnowboard Max
11                 d.setVar("INITRD_IMAGE","initramfs-netboot-image")
12                 d.setVar("INITRD_IMAGE_LIVE",d.getVar("INITRD_IMAGE",True))
13                 d.setVar("INITRD_LIVE","%s/%s-%s.ext4.gz" % (
14                         d.getVar("DEPLOY_DIR_IMAGE",True),
15                         d.getVar("INITRD_IMAGE_LIVE",True),
16                         d.getVar("MACHINE",True)
17                 ))
18         else:
19                 d.setVar("INITRAMFS_IMAGE","initramfs-netboot-image")
20                 if (d.getVar("KERNEL_IMAGETYPE",True) == "uImage"):
21                         # case for "old" u-boot images, like Porter board
22                         d.appendVar("INITRAMFS_FSTYPES"," ext4.gz.u-boot");
23                 else:
24                         # case for new u-boot images which don't require uImage format 
25                         d.appendVar("INITRAMFS_FSTYPES"," ext4.gz");
26 }
27