tests: Add new recipe for linus_stress
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / linus-stress / linus-stress.bb
1 SUMMARY = "linus_stress test"
2 HOMEPAGE = "https://chromium.googlesource.com/chromiumos/third_party/autotest/+/master/client/tests/linus_stress"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://${S}/linus_stress/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
7 SRCREV = "87cdfd4626c0cb47fc22f328867e49d6268df85c"
8
9 inherit autotools
10
11 B = "${WORKDIR}/git/linus_stress"
12 S = "${WORKDIR}/git"
13
14 # configure script is not delivered, only a makefile.
15 do_configure() {
16     :
17 }
18
19 do_install() {
20     install -d ${D}${bindir}
21     install -m 0755 ${B}/linus_stress ${D}${bindir}
22 }