Update github.com git:// SRC_URIs
[AGL/meta-agl.git] / meta-app-framework / recipes-security / cynagora / cynagora_2.1.bb
1 DESCRIPTION = "Cynagora service and client libraries"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cynagora;protocol=https;branch=${AGL_BRANCH}"
6 SRCREV = "7d7907651c42c5c32deabc17b639e0e1765eae60"
7 PV = "2.1+git${SRCPV}"
8
9 S = "${WORKDIR}/git"
10
11 DEPENDS = "systemd libcap"
12
13 inherit cmake
14
15 EXTRA_OECMAKE += " \
16         -DSYSTEMD_UNIT_DIR=${systemd_system_unitdir} \
17         -DWITH_SYSTEMD=ON \
18         -DWITH_CYNARA_COMPAT=OFF \
19 "
20
21 inherit useradd
22 USERADD_PACKAGES = "${PN}"
23 GROUPADD_PARAM:${PN} = "-r cynagora"
24 USERADD_PARAM:${PN} = "\
25 --system --home ${localstatedir}/lib/empty \
26 --no-create-home --shell /bin/false \
27 --gid cynagora cynagora \
28 "
29
30 FILES:${PN} += "${systemd_system_unitdir}"
31
32 PACKAGES =+ "${PN}-tools"
33 FILES:${PN}-tools += "${bindir}/cynagora-admin ${bindir}/cynagora-agent"
34 RDEPENDS:${PN}:append:agl-devel = " ${PN}-tools"
35
36 inherit ptest
37 SRC_URI:append = " file://run-ptest"
38 RDEPENDS:${PN}-ptest:append = " ${PN}-tools"