Update github.com git:// SRC_URIs
[AGL/meta-agl.git] / meta-app-framework / recipes-security / cynagoauth / cynagoauth_0.1.bb
1 DESCRIPTION = "OAuth server using cynagora backend"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cynagoauth.git;protocol=https;branch=${AGL_BRANCH}"
6 SRCREV = "26a5dbddf3a9bfde481a6fcd2aae16c7ecba665f"
7 PV = "0.1+git${SRCPV}"
8
9 S = "${WORKDIR}/git"
10
11 DEPENDS = "json-c libmicrohttpd openssl cynagora"
12
13 inherit cmake
14
15 EXTRA_OECMAKE += " \
16         -DDEFAULTHOSTS=:7777 \
17         -DDEFAULTURL=http://localhost:7777/tok \
18         -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
19 "
20
21 FILES:${PN} += "${systemd_system_unitdir}"
22
23