Update github.com git:// SRC_URIs
[AGL/meta-agl.git] / meta-app-framework / recipes-platform / packagegroups / packagegroup-security-framework.bb
1 SUMMARY = "Security middleware components"
2 LICENSE = "MIT"
3
4 inherit packagegroup
5
6 # Install Cynara and security-manager by default if (and only if)
7 # Smack is enabled.
8 #
9 # Cynara does not have a hard dependency on Smack security,
10 # but is meant to be used with it. security-manager however
11 # links against smack and expects Smack to be active,
12 # so we do not have any choice.
13 #
14 # Without configuration, security-manager is not usable. We use
15 # the policy packaged from the upstream source code here. Adapting
16 # it for the distro can be done by patching that source.
17 RDEPENDS:${PN}:append:with-lsm-smack = " \
18     cynagora \
19     security-manager \
20     security-manager-policy \
21     smack-system-setup \
22 "